All Collections
About Ligonier Connect
What are the system requirements to access Ligonier Connect?
What are the system requirements to access Ligonier Connect?
Find out what system requirements are necessary for Ligonier Connect.
Sam Rose avatar
Written by Sam Rose
Updated over a week ago

Ligonier Connect is designed to work well on most computers and mobile devices. Supported browsers include recent versions of Google Chrome, Edge, Safari, and Firefox. Other browsers (e.g. Opera, Internet Explorer) are not supported and may not function well. To check which browser you are using or download an alternate browser, this site is helpful: whatsmybrowser.org.

Did this answer your question?